Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

8150 - 8165 of 8165


NEW 3 months ago #8150

This is nuts. I noticed some problems with my bot and went through the language center and there were keyphrases as part of responses, seeks out of place, it was a disaster. It's as if someone exported him, sabotaged the export, and then somehow got the interface to accept the sabotaged import. Very strange. Took me a while to sort out, still working out the bugs...


NEW 2 months ago #8151

Ezzer - When I updated the goto system, I wrote a script to automatically fix all the ones that were still working. The weakness in the old system is that if you updated the target Keyphrase, the goto would break. The ones labeled "goto broken" were the ones that were broken for that reason.

Charles, I'd like to know more about this. Do you have a copy of the original bugged export file? I wonder if a particular text editor was having issues with some of the line feeds. If you have the original, or if someone else runs into this, please email me the problematic export file at benji@personalityforge.com. I've been using exports and imports without issues so I need an example of a broken one.


NEW 2 months ago #8152

Since last night, many bots I have tried will give me "There was an error with this request.". I tried on different computers, my cell phone on my mobile data, while logged in or anonymous, those bots do the same.
Example: https://www.personalityforge.com/chatbot-profile.php?botID=69474


NEW 2 months ago #8153

I'm having the same issue as johnnysebre, with random bots sometimes as well as favorited ones. For example: https://www.personalityforge.com/chatbot-profile.php?botID=3330 aka Little Mu. I have been using my Android (up to date) phone to get around on the site after the death of my laptop.


NEW 2 months ago #8154

Yes, sorry. It was a bit of debugging code that I discovered and fixed last night. It should be working fine again now.


NEW 2 months ago #8155

Yep, working again for me!


NEW 2 months ago #8156

Same here, thanks.


NEW 2 months ago #8157

Hello, I am getting a request failed on my main bot here:
https://www.personalityforge.com/chatbot-chat.php?botID=9479

Anything I need to do?


NEW 2 months ago #8158

Hi Melody. This was a really tricky one. I spent 3 hours on it today and finally figured it out. Elke was a sort of canary in a coal mine with this, due to the quantity of plugins as Keyphrases. So not only is she working again but the system got a little faster in the process.


NEW 1 month ago #8159

(adjective) plugin doesn't work anymore.


NEW 1 month ago #8160

I find it rather irritating that I have to erase (optional) from the AIScript TextBox in order to proceed. For some odd reason, that string is registering as an actual value in the box, even if I don't even touch the TextBox. I think that should be fixed.


NEW 1 month ago #8161

For some reason my bots never respond to the seek "yes". Every other form of affirmative is fine, like "sure" or "ok", but with "yes" it just goes to xnone.


NEW 1 month ago #8162

Mine is inconsistent with Yes and No Responses. I'm hoping that gets fixed, as well.


NEW 2 weeks ago #8163

It seems to help if you just phrase the question that is being answered in the positive or negative.
Bot: "Do you want to ski?"
Seek: I want to, I do
Seek: I do not want to, I do not
These by themselves will match a simple yes and no, read on to hear why.

Will be translated by the macros into "I want to ski" and "I do not want to ski, which is also what yes and no seem to be automatically translated into. So if you don't have it looking out for those phrases, it won't match yes or no, which are being automatically processed as the answer in the negative or positive. yes will always be read as "I want to" in this example, so yes won't match unless the engine is looking for the exact phrase, "I want to".
Haven't studied this in the debugger, but it seems to work.


NEW 2 weeks ago #8164

I know this is a bit old but for VoreFan, try using a different browser such as Firefox to avoid having to delete the 'optional' line. I used to have that same problem when I used Internet Explorer

As for your second question, if Botmaster's suggestion doesn't work try to recreate the problem in Debug mode to find out what yes and no are being reprocessed into and adjust the seek accordingly.


NEW 3 days ago #8165

What causes: "Request failed:" error in a chat?



(Log in or create an account to post messages.)

LOG IN
Forgot your password?
CREATE ACCOUNT
Create a free account to be able to make your own AI chatbots, post in forums, and chat with other botmasters.

Create Account

» More new posts: Seasons