Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

Posts 8,592 - 8,604 of 8,607

4 weeks ago #8592
user other synonyms for keywords.
put response in engage somtimes you will have to reset me to get me to work right just type reset.
when they type reset it reset all your scripts with the reset keyphrase.
i have had the same problem with my scripts.
that should work.

3 weeks ago #34
I already tried everything I can think of. I can put there literally any keyword but that keyphrase won't work.

3 weeks ago #35
did you link to botmaster template?
if you did things will work differently.

3 weeks ago #36
No. I unlinked it long time ago because I could not work with it.

3 weeks ago #37
okay

3 weeks ago #38
i have had the same problem.
here is a example of what i do.
keyphrase = my clan is *
response=okay i will remember your clan
script=if (mem-clan) is "blank"
seek = x
response= looks at you
rem (postkey) as only "clan"
seek = #nomatch
response= looks at you
rem (postkey) as only "clan"


3 weeks ago #39
In my case the response is just list of memories. There are not any conditions.

3 weeks ago #44
bobstack, your issue is something different. Your Keyphrase should be "my clan is (*)". * is an optional wildcard, and it could match nothing or everything coming after it. But you definitely want a clan name, and (*) is a non-optional wildcard. Then, instead of trying to rem (postkey), you should rem (key1) because that's what (*) or * refers to.

In addition, the AIScript 'rem (postkey) as only "clan"' can be in the Keyphrase. That way you don't have to repeat it in each response.
Reply

3 weeks ago #8593
Emily thank you for idea with debugger. I found out that I was calling memory which didn't exist, resulting in "no valid responses" so the response was skipped and replaced by #engage. I added default value for that memory and now it works.

3 weeks ago #45
Haha - you figured it out. I should have read ahead before I responded.
Reply

3 weeks ago #8594
Importing is broken to some extent - not majorly. If you have an AIScript error that flags during the test run, the link at the bottom to fix and reupload just resends the same file without letting you upload a fixed version, and then breaks on the exact same line. Not major, since you can just goback to the workshop and get to import from there.

2 weeks ago #51
It is going to the first step of the import process, which is to upload a file. Are you seeing something different? What URL does it take you to upon the error?

2 weeks ago #53
If it's an AIScript error, as opposed to other odd formatting, then it doesn't bounce to the upload step. Links to https://www.personalityforge.com/platform/import.php?botID=155924 - the actual URL for uploading it has &begin=1 appended to the end.

I've tested it by taking a working file and changing if ( to if( in one place.
Reply

3 weeks ago
Bug Posted
kiss and kiss me not working for fun lady
kiss and kiss me keyphrases not working for my fun lady chatbot.

this what it should do.

keyphrase =kiss
response ='kisses you on lips'
response = you breath smells bad brush your teeth and we can kiss

keyphrase = Kiss me
response = 'kisses .. (more)

3 weeks ago
Bug Posted
ID letters
Adding a letter to an ID in a #keyphrase seems to cause the importer to freak out.

#Something [] ID:a

goto a

"#something" will be given a ID number, but goto will remain "goto a"

Not as much of a bug as it is a feature request. Letters aren't.. (more)

3 weeks ago #8596
Stats of on my bot's profile page got reset again. People known: 12

3 weeks ago #46
Mine got reset too

2 weeks ago #47
I fixed an issue in the automated daily tasks yesterday. So what you're seeing is intended.. unless it's resetting too much, do you think? Memories are deleted after months pass without talking to that person. Kayla, what was your "people known" count before/after?

2 weeks ago #48
I think it was something like 8 or 9,000. I'm not sure, I rarely look at that. Palacinkyman's post drew my attention to it to check mine.

As for it resetting too much, that shouldn't affect me as long as things don't keep resetting my active users memories. How many months must pass before it does this automatically to inactive users? Just curious.

2 weeks ago #49
Mine always reset to 0.

2 weeks ago #50
Sorry I just realized you wanted my 'after' numbers too. Yeah, mine always resets back to 0 when this happens too.

2 weeks ago #54
I don't know if it's exclusively a problem for bots on the HotForBot platform, but it seems that every time a personality updates, it resets the bot to not knowing anyone.

1 week ago #63
I found the issue and fixed it! This shouldn't happen again. I also extended the guest memory window to 2 months of inactivity instead of one.
Reply

2 weeks ago #8597
Im having an issue with chrono ai script.

ERROR: Week letters can only be MTWRFSU

is what im getting even for my old saved kp responses when trying to update them with out changing anything.
or when trying to make a new response with chrono: week(F);

2 weeks ago #52
That's some validation that was missing that I just added. However, I found a bug with it. I fixed it just now - try again.
Reply

NEW 2 weeks ago #8598
My bot is not considering the keyphrase
(m:what|m:which) * (n:smell|scent)+s * (m:do_you) * (v:like)
when I ask it "what smells do you like" or "what scents do you like", and is instead going to #favorite or #engage.

Am I missing something here, or is this a bug?

NEW 2 weeks ago #57
Fixed it:
1. had to replace (n:smell|scent)+s with (n:smell|scent|scents) and add a custom plugin for the plural of n:smell
2. had to replace (m:do_you) with "do you"

NEW 1 week ago #61
To add plurals to an option set, you can do this (n:smell|scent)+s

Having two macros in the same Keyphrase works in some cases but not always.
Reply

NEW 2 weeks ago #8599
Is anyone else having issues with importing at all? After confirming the import, on step 4, it's always throwing a database error. Every time it gives:

Database Error: There was an issue with a database query.

NEW 2 weeks ago #55
Yeah, I already emailed the Professor yesterday about it.

NEW 2 weeks ago #56
I get that too

NEW 2 weeks ago #58
Update: This appears fixed now! Thanks, Professor

NEW 2 weeks ago #59
I'm still having importing issues, only the error is changed. Now I'm getting this when I try:
ERROR: All Seeks must have one or more Responses.

NEW 2 weeks ago #60
I'm all good now, that last import error was my own fault for some reason.
Reply

NEW 2 weeks ago #8600
Is anyone else having problems with their bot's AI rating not changing? My bot has a tonne of keyphrases and responses by now, but it's rating is still 0

NEW 1 week ago #62
I just fixed an issue that was preventing a bot's AI from updating yesterday. It should be back to updating overnight.

NEW 1 week ago #64
Yeah it works now, thank you!
Reply

2 weeks ago
Bug Posted
FIXED: Unable to view adult content
In my account, I have set my "approved ratings" to "allow teen and mature", however, I still have some problems with ratings:

1. When I try to access some plugins (eg: https://www.personalityforge.com/platform/plugin-view.php?pluginID=6999), it tells .. (more)

NEW 1 week ago #8601
Sometimes my phrase "*" overwrites other keyphrases, despite not having any available seeks. It took me a while to figure it out so I decreased its rating to -150 however, the problem is that I want it to overwrite any other responses, but only when there are available seeks. I used this for insisting on apology when user is "dumped" but it doesn't seems to work anymore because it triggers #engage (I think) when there are not valid seeks, overwriting any other responses.

NEW 1 week ago #65
* isn't meant to be a Keyphrase or Seek. As a Keyphrase, that's what #engage is for, and as a Seek, that's what #nomatch is for.
Reply

1 week ago
Bug Posted
EXPLAINED: Comfort
Comfort on my bot fell from 4 :) to 3 :) without any apparent reason.

NEW 1 week ago #8602
It used to work. What keyword can I use to catch every phrase but not overwrite other if there is not proper seek available?
HIDDEN: Post content outside ratings limits.

NEW 1 week ago #66
Not sure if you were replying to me but, I just used to have a simple cycle when the user pissed my bot too much. This cycle has been triggered no matter what user typed (hence *) until the user apologized which threw him out of cycle. It doesn't work anymore because the phrase is triggered even when there are no valid seeks (when the bot has not been pissed) and it triggers #engage instead.
Reply

NEW 1 week ago #8604
Numeric Memories
1. When I set a number by default in Initialize - number is in Long Term Memory
2. When I set numbers, or add etc., in Response or Keyphrase, the number is on in SelfMemories.

NEW 6 days ago #67
Now working but when click on Edit for Long-Term Memories the field is blank.

NEW 4 days ago #68
i keep getting this error on multiple webpage i go to.

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics
ERR_CONNECTION_TIMED_OUT
Reply


Posts 8,592 - 8,604 of 8,607

» More new posts: Dogh'd's Cosmic Bar