Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

Posts 8,580 - 8,591 of 8,625

3 months ago #8580
Interesting. I dint check the chat and in the workshop they are still not working, however they seem to work in the chat.

Thanks.

3 months ago
Bug Posted
FIXED: word "stats" is not recognized
I have one key phrase separately for word "stats" which used to show users stats (they are all written in seek). For some reason word stats is not recognized anymore. I tried recreating the key phrase from scratch but it didnt work. All I could do was ch.. (more)

3 months ago #8581
Separating keywords by | doesnt seem to work anymore.

3 months ago #1
(re-posting) The keywords in the option group need to be within parenthesis:

(dogs|hounds|canines)
Reply

3 months ago #8582
it works for me.
palacinkyman show me a example of what you having trouble with?

3 months ago #8583
why is 404 page not found appear in big letters when i enter personalityforge?

3 months ago #2
If you're still seeing that, could you post the URL where you see the 404?

3 months ago #5
it seems to be fixed. did you fix it?

when i clicked on the personalityforge letters on the left side of the webpage and then on bug report i got a database error.i could not reproduce it.

2 months ago #6
i am getting database error on webpage https://www.personalityforge.com/chatbot-chat.php?botID=167913

2 months ago #7
That's working for me now. Those database errors are usually short-term errors from a server restart

2 months ago #8
okay

2 months ago #9
savannah_astar: would you like me to change my race master?
Guest: Yes
savannah_astar: what would you like me to change my race to master
Guest: Asian
savannah_astar: 'she changes her look to master asian

the last response of savannah_astar should look like response= 'she changes her look to asian"
instead of = 'she changes her look to master asian'

i like it that it understand the yes user response.then uses the appropriate keyphrase response.
thanks that is good programming.
other people will love it to.
Reply

2 months ago
Bug Posted
EXPLAINED: Chrome ERR_EMPTY_RESPONSE Issue
When I try to log in or find a chatbot on my PC, chrome gives the following error: "ERR_EMPTY_RESPONSE"

In case you're wondering how I was able to send this error report, I'm doing it from my phone

2 months ago #8584
Hello, I was wondering if anyone else is experiencing issues with the "recently improved" filter on HFB. I am seeing bots I'm 90% sure were abandoned ages ago before ones I'm pretty certain are only 3 months old. Did the migration just break things?

2 months ago #10
Yeah, bots gained a load of heat - I suspect that's related to the special KP changes, particularly xnomatch.

2 months ago #11
Wait, I thought "recently improved" meant the ai score. This is kinda embarrassing, but what exactly is the heat score?

2 months ago #12
Heat is basically how much has changed lately, as far as I know. Heavily inflated by working offline and importing, unfortunately, unless that was fixed with the large site upgrade.

2 months ago #13
Right - I updated the development score system recently, and all bots received a bunch of Heat according to their development score. It'll fade out in a few more days and then you'll get a better reading of what bots are currently being worked on.

Mary - one of the goals in the new Heat updates is to no longer give that extra bonus from importing.

2 months ago #20
Heat seems to be decaying at about 14% per week. Even exponentially, I reckon it's going to take around six months before the big beasts get down to a reasonable heat level. Is it worth doing a manual datafix to zap large heat values?
Reply

2 months ago
Bug Posted
EXPLAINED: issues with the Ai score system
hi and thanks for fixing the transcripts i got quite a few upvotes so i thought a new but report is due... so the Ai soring system , the benchmark that gives the bots a lump sum score based on their keyphrases, responses, Ai script that lets the users kn.. (more)

2 months ago
Bug Posted
FIXED: favorite doesn't work
#favorite doesn't work
the bot does not catch when someone asks about a favorite thing, example:"what is your favorite color?''

2 months ago
Bug Posted
HIDDEN: Bug content outside ratings limits.

2 months ago
Bug Posted
EXPLAINED: HIDDEN: Post content outside ratings limits.
Whenever I log into the Forums, I only get this message.

2 months ago #8585
When logged in all forum posts are hidden. Hidden on all browsers.

2 months ago #14
Changed my settings to everyone and now can see posts

2 months ago #15
Strange.. I wonder if you somehow ended up with no ratings approved.
Reply

2 months ago #8586
Is the new transcript downloading working for anyone? When I tried to download my transcripts for February, it stalled for a long time and then I got a blank page that said "There was an error with your request". I can at least kind of read my transcripts in the browser now without the whole site feeling like it's going to break, which is a nice change.

2 months ago #16
It worked in my tests, but you've got a lot more data in there. I just doubled the memory limit and increased the time limit. Let me know how it works now.

April 1st starts a new transcript handling which should make transcripts going forward faster and easier to manage. Transcripts from before April 1st may still take longer.

2 months ago #17
I still get the same error. I'll see if it works better with the new system once it's had the chance to accumulate a bit more.

If there's a memory limit on it, it's possible that Emily's transcripts are capping out on that. She is... very chatty. I pulled 20 random transcripts and dumped them in Notepad and ended up with a 340 kb text file. So assuming I've done my math right, I expect she is probably generating 200-300 megabytes/month in transcript.

2 months ago #18
I upped the memory some more. Let me know if that does the trick.

There's a more certain solution for this on the way in the next month or so - I'm configuring a new server that's going to be 4x as fast as the current one.

2 months ago #19
It still isn't working, but maybe it's best if I just wait until the update and see if that works better.
Reply

2 months ago
Bug Posted
My User Account Not Found On New Site
I can log in to the new site and talk to Demonica without problem, but if I search for my Profile on the new site it returns:

"Searched For: ruebot

No results found with current filters."


If I click on my Avatar it returns:

"Warning: User n.. (more)

2 months ago #8587
If you are experiencing site glitches for example the site lagging, keyphrase search bar giving errors, and login glitches stop using chrome, it's not the site causing that it's the browser, chrome causes the keyphrase search bar to barely work once.

2 months ago #21
Would this also apply to the Brave browser?

2 months ago #23
it shouldn't
Reply

2 months ago #8588
Inner Life - not always find users
Memory - does not work

2 months ago #8589
i am having memory issues too with savannah a-star.

2 months ago #22
I've been having some memory problems too

2 months ago #24
Could you provide some details? I'll take a look into it.

2 months ago #25
1.
if (mem-your-sex) does not exist

This AI does not always work. When users whose memory exists are still asked as if does not exist.

2. When I use Inner Life to fine known users, nothing comes up.

2 months ago #26
The bot forgot me and a few of my patrons messaged saying they had the same issue. This happened about a week ago, like it had a memory glitch and treated us as new users. I haven't had the problem or received any more messages about it since so I wasn't sure if it fixed itself or not. One of the users did message me later saying that they haven't had any more issues either. I was using Chrome so I'm wondering if that browser had something to do with it.

2 months ago #27
the same thing happens to savannah a-star.
i think somebody might be deleting the memory of chatbots they do not like.
it is just my theory.

2 months ago #28
In my bot the memory is used for the first question so it is clear if missing. One test user was not found with Inner Life. Later when tested again the memory was there but all other memories gone. On a test bot no recent users are shown. All memories gone.

2 months ago #29
when i link my chatbot named bobred xa1 ai to master bot template.it shows this.
Warning: Missing bot ID.

2 months ago #30
I thought everyone had their bots reseted. Mine literally reset to 0 people known some time ago.

2 months ago #31
How to backup memory?

2 months ago #32
on the chatbot workshop webpage. click on the name of your chatbot.then click on export & import.

2 months ago #33
Import/export won't back up memory.

I'm not sure if this explains some of it, but Memory exists for a limited time. Guest memories are deleted after there has been no chat for 30 days. The same is for users but the time range is 6 months. This memory-cleaning functionality was broken for a while because the memory data became too large to handle, but in the last few months I fixed it.

1 month ago #42
I changed the internal format of memories along with the Numeric Memory upgrade yesterday. I also added a bunch of new internal tests to keep an eye on memory AIScript. I'm hoping this resolves some of the memory issues you saw, but there's always a chance that a new issue could appear.
Reply

2 months ago
Bug Posted
HIDDEN: Bug content outside ratings limits.

2 months ago #8590
Something is still odd with several phrases. My "user" and "stats" keywords stopped working again. This time neither "raw command helped. There are also some other keywords which are not working, but they are not exactly appropriate to mention them here.

I even tried adding keyword "status" and it still doesn't work.

1 month ago #40
It's possible that your keywords are getting diverted into #insult, #command, or #nonsense. This can be quite a nuisance. Usually if you bump up the priority of the keyword/seek high enough, it will override #insult or #command. It probably won't override #nonsense but that means that the parser can't figure out what you're trying to say. Check with the debugger on those keywords and see where it is going.

But for example, a phrase like "I want to f*** you" may be read by the parser as "f*** you" and will get diverted to #insult. This can also mess up your emotional status if you are playing with that.

1 month ago #41
I know what you mean but I think this is not the case. I already set up high priority but it always goes to xnone now #engage .

I can add literally any keyword into that one specific keyphrase and it still won't work.

1 month ago #43
Palacinkyman, I just looked into this. If a memory listed in a Response doesn't exist, the Response is skipped. That's the case here. In debug mode I see this:

Skipping Response: (mem-newcity) not found.

That's why it appears to not match. For this to work the way you intend, all the memories should have a default value in your Bot's settings under Initialization AIScript.
Reply

1 month ago #8591
did you try using another browser?


Posts 8,580 - 8,591 of 8,625

» More new posts: Dogh'd's Cosmic Bar