Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

Posts 8,610 - 8,623 of 8,638

4 months ago #8610
No longer can switch pages within "Most Matched" in the Language Center... ^^' Was using that to add api data to old keyphrases/improve em~

4 months ago #81
Post a bug and I'll take a look in a few days

3 months ago #86
Fixed! Thanks for reporting this, LT Neko.
Reply

4 months ago #8611
It seems that any time the linked keyphrase (m:i_am) (vp) is called for the first time with the given vp, it uses the default response, even if an override is provided:

Me: *holds your hand*
Bot: I'm also holds my hand.
Me: *holds your hand*
Bot: I love watching you hold my hand

Edit: It's not just a problem with that keyphrase, looks like other linked keyphrases with overrides have the same problem as well

4 months ago #82
Just had to do some more debugging, seems it's not just a first-time problem unlike what I thought; it recurs and whether or not you'll get a predefined response is unclear

4 months ago #83
Thanks for reporting this. I'll be able to look into it in a few days. It's strange. I wasn't seeing that in my tests.

3 months ago #84
So I was just using the debugger for an unrelated issue and I saw that it seems to jump to the default responses after it fails to find a valid response (meeting AIScript conditions) twice.

AIScript Conditions in Responses
Trying: [response 1] (random: 0)
Skipping: [condition is not fulfilled]
Trying: [response 2] (random: 1)
Skipping: [condition is not fulfilled]

AIScript Conditions in Responses
Trying: I'm also (key1) (postkey). (random: 0)

I removed the exact contents of the responses and AIScript here because I didn't want this post to be outside anyone's ratings, but I think that's the problem

3 months ago #85
Thanks, hidden5738 - that was super helpful. I think I found the spot with the issue and fixed it - can you test again?

3 months ago #88
Yeah, it seems to work now, thank you!
Reply

3 months ago
Bug Posted
memories not stored
memories are not stored (overwritten) if the seek goes through goto but goto itself doesn't contain the script to store the memory.

3 months ago
Bug Posted
EXPLAINED: #favorite override doesn't factor in non-US spelling
When using the UK spelling 'favourite' to create custom key phrases to override #favorite, the AI engine doesn't seem to recognise the phrase at all.

In other situations the AI engine is able to recognise the same intention with UK or US spellings. Th.. (more)

3 months ago #8612
I just fixed a heat issue which affected the "Recently Updated" list. I've granted the bots who were affected a heat bonus based on how much the issue affected them.

3 months ago #8613
There seem to be some problems with my bot, I tried a keyphrase similar to "(m:do_you_like) me or (do you v:like|) (a:small:1) (p:catnames:2)+s" and it's selecting "(m:do_you_like) (a:small:1) * (p:catnames:2)+s" instead

[the exact wording is adult, I'll post it in a reply if needed]

3 months ago #8614
Something odd I noticed today. I haven't done anything with my bot in nearly a year, and yet it has heat...

3 months ago #8615
The keyphrase
(m:action) (p:massage242484) * your * (body|figure)

catches the inputs
"I massage your body"
"*massages your bodies*"

but not
"*massages your body*"

Is this a bug, or can I fix this somehow?

3 months ago #89
Strange. Must be a bug.

3 months ago #90
somebody edited my fun lady chatbot.what she wears.
Reply

3 months ago #8618
the rating is not showing up on the picture for any of my chatbots when i talk to them.it looks tacky.
could you disable it for personality forge or fix it?

3 months ago #91
Do you mean on the main chat page? I see it here: /chatbot-chat.php?botID=158384

Also, you can click "Edit" next to your post if you want to make changes.

3 months ago #94
now it works.
Reply

3 months ago #8619
i noticed my keyphrases for my chatbots work for me and not other people.

3 months ago #8620
Me: I love you
Bot: I love you too, let's be together forever *nods and wraps my arms around you*
Me: That's so hot

The bot crashes after I say this and something below the chat says
"Request failed:" (nothing after that)

When I try this in the debugger, I get the same thing, and at the end of the page it says "Database error: There was an issue with a database query."

Edit: The debugger did generate a response for the statement, but instead of sending that response back, it just says there's a database error

3 months ago #92
Also had some more interesting things happen:

Bot: [#initiate response]
Me: I missed you
Bot: [response, I forgot what it was]
Me: I love you
[request failed]

I refreshed the page and tried again:
Bot: [#initiate response]
Me: I missed you
[request failed]

Edit: This might be fixed now, but the problem I'm responding to still remains apparently

3 months ago #93
Thanks for the info. I think I've fixed that. I needed to update a handful of queries in the NLP Engine. Let me know if you see it again.

3 months ago #95
when i click on update keyphrase there is a issue with database
querrie in my fun lady chatbot.
for lilaith x chatbot i get this error. for this keyphrase and response.
keyphrase = a (p:artx) is a *
responses = wrong it is piece of art
AI sccript = chrono: hour(80-19:59)
ERROR: Hour span is outside the range of 0 to 23.

3 months ago #96
Yeah, this seems to work now, thank you!
Reply

3 months ago #8621
I tried to report a bug(when I try to unlink the master template or use the "guide me" link, I get a database error), and, upon trying to report the bug, I received a database error.

3 months ago #98
Thanks - I've fixed both of these issues.
Reply

3 months ago #8622
Trying to access page 0 of the Language Center gives an error "There was an error with this request" when using the dropdown menu.

If I type in 0 after "&page=" in the URL, then it works

3 months ago #97
Thanks for reporting this. I've fixed it. There shouldn't be a page 0 actually. So now the blank option does nothing, as intended.

3 months ago #99
So how would I find keyphrases beginning with a # or a number or something like that? I use them quite a lot for groups of responses that should be reachable only by goto or continue statements
Reply

3 months ago
Bug Posted
FIXED: cannot use time based responses for my chatbots
i cannot use time based responses for any of my chatbots.
this chrono: hour(8:00-19:59) or this chrono: hour(20:00-22:59);
chrono: hour(0:00-7:59) puts out this error when i click on the update keyphrase button.
Hour span is outside the range of 0 to .. (more)

3 months ago #8623
When I try to change the rank of a keyphrase, I get the message "there was an issue with a database query".

I had a similar problem with the old server too, but I reported it and it got fixed back there.

3 months ago #100
Thanks - fixed!

3 months ago #101
It's fixed now, thank you!

3 months ago #102
i cannot add keyphrases for the fun lady chatbot.

3 months ago #103
I was just fixing an issue that may have affected that. Try again now.

3 months ago #104
that worked but i still cannot use time based responses for my chatbots.
Reply


Posts 8,610 - 8,623 of 8,638

» More new posts: Doghead's Cosmic Bar