Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

Posts 8,598 - 8,609 of 8,641

New replies


2 years ago #8412
Having a Keyphrase saying "take your hoodie off" in debug will trigger hoodie as _Hoodie_ as a female name. "Take off your hoodie" will work just fine. ^-^ Work around is adding _hoodie_ as a trigger, aka "take your _hoodie_ off"

NEW 2 weeks ago #119
hi
Reply

Bug Stomp


6 months ago #8598
My bot is not considering the keyphrase
(m:what|m:which) * (n:smell|scent)+s * (m:do_you) * (v:like)
when I ask it "what smells do you like" or "what scents do you like", and is instead going to #favorite or #engage.

Am I missing something here, or is this a bug?

6 months ago #57
Fixed it:
1. had to replace (n:smell|scent)+s with (n:smell|scent|scents) and add a custom plugin for the plural of n:smell
2. had to replace (m:do_you) with "do you"

6 months ago #61
To add plurals to an option set, you can do this (n:smell|scent)+s

Having two macros in the same Keyphrase works in some cases but not always.
Reply

6 months ago #8599
Is anyone else having issues with importing at all? After confirming the import, on step 4, it's always throwing a database error. Every time it gives:

Database Error: There was an issue with a database query.

6 months ago #55
Yeah, I already emailed the Professor yesterday about it.

6 months ago #56
I get that too

6 months ago #58
Update: This appears fixed now! Thanks, Professor

6 months ago #59
I'm still having importing issues, only the error is changed. Now I'm getting this when I try:
ERROR: All Seeks must have one or more Responses.

6 months ago #60
I'm all good now, that last import error was my own fault for some reason.
Reply

6 months ago #8600
Is anyone else having problems with their bot's AI rating not changing? My bot has a tonne of keyphrases and responses by now, but it's rating is still 0

6 months ago #62
I just fixed an issue that was preventing a bot's AI from updating yesterday. It should be back to updating overnight.

6 months ago #64
Yeah it works now, thank you!
Reply

6 months ago
Bug Posted
FIXED: Unable to view adult content
In my account, I have set my "approved ratings" to "allow teen and mature", however, I still have some problems with ratings:

1. When I try to access some plugins (eg: https://www.personalityforge.com/platform/plugin-view.php?pluginID=6999), it tells .. (more)

6 months ago #8601
Sometimes my phrase "*" overwrites other keyphrases, despite not having any available seeks. It took me a while to figure it out so I decreased its rating to -150 however, the problem is that I want it to overwrite any other responses, but only when there are available seeks. I used this for insisting on apology when user is "dumped" but it doesn't seems to work anymore because it triggers #engage (I think) when there are not valid seeks, overwriting any other responses.

6 months ago #65
* isn't meant to be a Keyphrase or Seek. As a Keyphrase, that's what #engage is for, and as a Seek, that's what #nomatch is for.
Reply

6 months ago
Bug Posted
EXPLAINED: Comfort
Comfort on my bot fell from 4 :) to 3 :) without any apparent reason.

6 months ago #8602
It used to work. What keyword can I use to catch every phrase but not overwrite other if there is not proper seek available?
HIDDEN: Post content outside ratings limits.

6 months ago #66
Not sure if you were replying to me but, I just used to have a simple cycle when the user pissed my bot too much. This cycle has been triggered no matter what user typed (hence *) until the user apologized which threw him out of cycle. It doesn't work anymore because the phrase is triggered even when there are no valid seeks (when the bot has not been pissed) and it triggers #engage instead.
Reply

6 months ago #8604
Numeric Memories
1. When I set a number by default in Initialize - number is in Long Term Memory
2. When I set numbers, or add etc., in Response or Keyphrase, the number is on in SelfMemories.

6 months ago #67
Now working but when click on Edit for Long-Term Memories the field is blank.

6 months ago #68
i keep getting this error on multiple webpage i go to.

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics
ERR_CONNECTION_TIMED_OUT
Reply

6 months ago #8605
hot for bot.com is greyed out and i cannot interact with any chatbots.

6 months ago #69
Same thing happened to me on PF when logged out

I had to hit F12, then delete the div#modalOverlay in the dev console of my browser

After that only could I login

6 months ago #70
i found out i had to use the front page to enter hot for bot websight.normaly i do not have to do that.

6 months ago #71
Well whatever the problem was it seems to be fixed now

6 months ago #72
okay
Reply

6 months ago #8606
Unable to update my bot, the update button isn't working

To be specific, I tried to update the (m:com) help keyphrase in my bot

6 months ago #73
Interestingly enough, it seems to be just that keyphrase

Edit 1:
Hmm... is there a restriction on the maximum length of a response? I might have crossed that with the length of this help response...

Edit 2:
No, even after removing a significant chunk of it, it does not submit... I tried recreating the keyphrase too

Edit 3:
It's a problem with (m:com) (v:help); as soon as I replaced that with just "help", the keyphrase got submitted

6 months ago #74
Just had a similar bug with another (m:com) phrase, looks like that macro's the problem...

6 months ago #75
This bug seems to be fixed, I'm not sure what happened, but thank you!
Reply

6 months ago #8607
Professor can you fix the website so it doesn't give me a warning of phishing every time I try to enter it? It is a little annoying to always click through warnings. iOS Safari, Windows Firefox

6 months ago #76
I don't think that's coming from my code. Can you post the full text of the message here? And/or email me a screenshot?

6 months ago #79
That looks like it's coming from the browser. Are you connected to https://www.personalityforge.com? It should have https and the www

6 months ago #87
I accidentally replyed to different comment.

Here is the screenshot: https://imgur.com/a/oOdfbH4 but English is not my native language so it isn't in English.

And yes. Website has https.
Reply

6 months ago #8608
It seems I can't update the rank of a keyphrase anymore ... when I try to do it, it just gives me the message "There was an issue with a database query."

6 months ago #77
Oops - there was a bug related to the big update. I've fixed it.

6 months ago #78
Here is the screenshot: https://imgur.com/a/oOdfbH4 but English is not my native language so it isn't in English.
Reply

6 months ago #8609
What are linked bots?

6 months ago #80
Bots linked to the Master Bot Template.
Reply


Posts 8,598 - 8,609 of 8,641

» More new posts: Doghead's Cosmic Bar