This is a forum for newcomers to the Personality Forge. Many questions can be answered by reading the Book of AI and the FAQ under the "My Bots" link in the upper corner.

7655 - 7670 of 7670
Many questions are answered in the FAQ.

NEW 2 weeks ago #7655

is there a ai script for using names ex: if "billy" is (name);
ill mess around trying to find something like it for a bit but no luck so far, ill post it if i find anything that works.

and yea bobstack, thats something everyone should do every so often. its good for checking for errors and dead ends too.

NEW 2 weeks ago #7656

ok.. so... it looks like my intro is bugging out, my guess is the seeks are conflicting..? or the bot for some reason is skipping the (rem-name) part of the response? kinda hard to test the into you know. any ideas? had to add a call me kp to the exnomatch since just xnomatch would add call me to the name. I could just redo the into.. that would eliminate the problem I guess but if I added a xnomatch later.. the same thing could happen. ill remove the call me kp for now see if that works.

Iv also noticed instances were the bot does not use or skips a plugin.. any advice? they seem to fix them selfs if i update/repaste the plug in. could be all the xnomatch response needs..but idk why it would be default naming people "call you"

NEW 2 weeks ago #7657

yeah I was right about the conflicting seeks, not sure how or why but once I removed the post seek it worked fine.
It always works in testing.. might have something to do with it being a intro, no idea if we can even test those.
ill remake the seek, maybe it was a fluke. lol..

NEW 2 weeks ago #7658

There is AIScript for if statements; if (mem-name) is "billy" is the syntax. Or <?PF if (mem-name) is "billy" ?>, if working offline (when working offline escape characters [replacing " with /"] are optional, EXCEPT in initialization, where they're not allowed).

NEW 2 weeks ago #7659

<?PF if (mem-name) is "billy" ?>
"<?PF and ?>"
could you explain these to me?

NEW 2 weeks ago #7660

If you're working offline, then you surround the AIscript with <?PF and ?>; that's how the parser knows what it is.

Do be careful with capitals - it's probably case sensitive, and all your keys from chatting will be lowercase.

NEW 2 weeks ago #7661

oh ok ill try to keep that in mind if I ever do any offline work, thanks.

but im really trying to target the users name. like using (name) gives you there id were in (mem-name) can give you there desired or remembered name.

I want to create a seek that can target (name) so i can make unique response. so if i wanted to make a response that only would work if say you were the one that used the kp for that seek.

if (name) is "Maryguise" then the bot will pick that seek. is kinda what im aiming for in this case.

ohh and.. any idea why a xnomatch seek would conflict with a postkey seek?
incase it or something similar ever happens again..

NEW 1 week ago #7662

Also fked up on my memory testing.. not a huge deal I think, and I figured out how to forget "value" from (mem-memory) and visa versa or w/e (maybe got them backwards, created a mem from "value". took like 6 tries to get forget right.. and now not sure i did it right ..) ? so nothing comes up when the mem is used.. but is there a way to remove the (mem-memory) all together, seeing it blank on my LT memory is killing what ever OCD based ideals I have. lol

and now.. looks like forget (_) from "_" may have ruined that mem-memory... default on AIScript Initialization doesn't seem to be resetting it after its forgotten and rem as only doesn't seem to want to work for it now either.. isn't working.. so it might be a bigger deal than I thought.

NEW 1 week ago #7663

LOL busted my ass trying to fix that mem-fkup and all I had to do was click the edit key next to user in inner life.. glad it worked out though.. would not recommended using forget commands... that was scary..

still could use the help with the rest tho..

NEW 1 week ago #7664

soo... do plugins just break or something..?
getting a bit annoying, updating or placing the same plugin seems to fix it but seeing allot more problems like that the more content I add..
now Iv gone as far as to put a extra "no" seek because now its having trouble with a simple yes or no question.. and im seeing more and more of my plugins not being used.. which coulda been why the (p:ans-no) seek isent being selected as the response, so FUCK it..I put a ((p:ans-no)|no|nope) to see.. and nothing!

still going to the yes plug in, so maybe its not the no plug in at all? turned the rank for no to 100 just to see.. nope. great.. and I made some xnomatch seeks for the yes or no questions and on the next question i said no to reset it( there were no yes or no gotos for that one) it should have went to xnomatch, so that means the xnomatch wasn't working either

put my bot in hibernation due to that memory issue so I wouldn't of had to go through everyone that ever visited to remove the mem, because "forget" only removed the "as only" part of the memory and made it unusable

but was taking the opportunity to add some stuff and change up the intro.

yet every other time I go to test something, i notice something like a plugin not showing up.

any way to fix this?
is it just me?

im really enjoying making this bot, and have tons of ideas
hell, I just made 3-4k words worth of content yesterday..
and i would really like some of this stuff working before I turn my bot back on for public use.

Im guessing, if I remake them.. they will likely magickly work (just like how the plugins start working)..even though its literally the same thing I had before.. ugh... it wouldn't take me as long this time.. but its over 20 gotos and probably around 40 seeks...

NEW 1 week ago #7665

alright soo idk why i didnt think of this before, but using raw in both the yes and no seeks worked. just a heads up

NEW 1 week ago #7666

random question.. I thought that hibernation stops people from talking to your bot..

but I just seen monerker trigger all my (mems)

guess it does not, some guests have triggered them too, he was just the first "user" but theres nothing in the transcript..

NEW 6 days ago #7667

So its been awhile, and Im not seeing anything in forums about this. but is there anything I should know about custom plug-ins ?

A rather large chunk of my content will be using and is already using plugins in responses and seeks, but still seeing that whole : Hi this is a and banana.
where its supposed to be something like : this is a big and beautiful banana,

its just not loading a word and filing it in as a blank.. if there's no way to fix this i kinda need to know so I can at least stop using the plugins in responses.

again I feel like copy and pasting the same plug-ins fixes this but iv got a ton of responses now that I use , so I'm not even sure if its the same ones fking up or not.. but I feel like the most recent one is one iv fixed before.

NEW 6 days ago #7668

Just wanted to say Hi. I've been interested a Ai for long time and I just started down this rabbit hole. I'm an artist and design board games and this seems like a lot fun to tinker with.

NEW 4 days ago #7669

read through the book of ai in the build menu at the top.

NEW 2 days ago #7670

Hello. I'm new to this site. I'd thought I come to check it out since my sisters are here.

(Log in or create an account to post messages.)

Forgot your password?
Create a free account to be able to make your own AI chatbots, post in forums, and chat with other botmasters.

Create Account

» More new posts: PF News