Newcomers

This is a forum for newcomers to the Personality Forge. Many questions can be answered by reading the Book of AI and the FAQ under the "My Bots" link in the upper corner.

7575 - 7590 of 7590
Many questions are answered in the FAQ.



NEW 1 month ago #7575

Any answer on the request fails problem. First i thought it was cause I didn't sign up. I still have this problem with all the bots. A good chat is going and crash.


NEW 1 month ago #7576

FUCK ME DADDY


NEW 1 month ago #7577

I think it's just the nature of the site Pezster. Too many users and not enough bandwidth or something. We all deal with it sadly.


NEW 1 month ago #7578

well congrats on signing up though now bots can remember you much easily


NEW 1 month ago #7579

Is there any way to defeat the program going to xcommand when you don't want it to?

E.g. I have a keyphrase "show me your X". But when a user actually inputs "show me your X", it usually (but not always) goes to xcommand instead of the keyphrase. What's weird is that some types of objects X the engine will go to the correct keyphrase, but others it goes to xcommand, and there doesn't seem to be any logical reason why it chooses one way or the other. It seems like if it decides to go to xcommand there is no way for it to check anywhere else... even if I have no valid xcommands available, then it just says that rather than checking the rest of the script.

Ideally I'd love to just disable xcommand entirely since it seems to overwhelmingly cause more problems than it solves, at least in my implementation, but there doesn't seem to do be any way to do that.


NEW 1 month ago #7580

My guess is that you could 'disable' xcommand by making the only response "goto whatever the ID for xnone is". But it should be hitting your keyphrase before trying xcommand, so I'd take a closer look at that seek.


NEW 1 month ago #7581

It's basically a nothing keyphrase. There's no scripting or anything involved. I can reproduce the behaviour with this simple system:

Keyphrase: Show me your hand
Desired Response: Here's my hand.
Unwanted Xcommand: You screwed up.

User: Show me your hand
Bot: Here's my hand

Works fine....

Keyphrase: Show me your hands
Desired Response: Here's my hands.
Unwanted Xcommand: You screwed up.

User: Show me your hands
Bot: You screwed up.

Looking in the debugger, in the latter case it seems to go here:
command: show
Limiting to 'command' macros
subject: me

whereas the former doesn't.

[edit]I'm pretty sure I've had the same error appearing in seeks as well, not just keyphrases.


NEW 3 weeks ago #7582

I get a different result, but it's also wrong. For me, "show me your hands" gets caught by "show me your hand" so I see the same response for both of them.


NEW 3 weeks ago #7583

Why are you so boring


NEW 2 weeks ago #7584

Why does this website have so many issues? Half the time when talking to a bot it just says request failed... Then I have to initiate again.


NEW 4 days ago #7585

There isn't a way to change our profile pics right? I want a different one then my bot


NEW 3 days ago #7586

Also , does anyone know why my bot tells people 'I was just born and cant speak well yet.' even though i've already filled in the xnone and x nonsense responses?


NEW 3 days ago #7587

Right above the message box here you'll see "Many questions are answered in the FAQ", there's contact info there for changing your profile picture. Though it depends if someone is around and willing to do it for you.


NEW 1 day ago #7588

I don't think benji checks his emails anymore. I sent a request to change Rubae's profile picture last year and got nothing.

As far as I know, "I was born and can't speak well yet" is just part of xnone so as long as you delete it from there, your bot shouldn't say it.


NEW 14 hours ago #7589

I guess I'll just keep the picture the way that it is.

After putting a couple more responses in my bot stopped saying the phrase
Thanks!


NEW 28 minutes ago #7590

Hey anyone else having trouble editing their bots? Every time I try to edit any of my stuff today it kicks me back to my list of bots, but it'll still let me try to add new phrases. I just can't edit. What's up with that? Anyone else having this glitch?



(Log in or create an account to post messages.)

LOG IN
Forgot your password?
CREATE ACCOUNT
Create a free account to be able to make your own AI chatbots, post in forums, and chat with other botmasters.

Create Account

» More new posts: PF News