Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

8140 - 8154 of 8173


NEW 10 months ago #8140

Has anyone else noticed problems with ^ and $ no longer working? I'm starting to see seeks and other things fail because of it. And removing them leads to a lot of silly responses.


NEW 10 months ago #8141

@ Nathan S : with my bot it works. Except just for a couple of words in which i used ^ and $
Have you checked them all?


NEW 10 months ago #8142

I believe so, after playing around with it some I discovered that using raw can be used as a substitute, so it's all good.

I dunno, I get really paranoid that one day my bot is going to break down and cease functioning properly. So I tend to freak out when things stop working lol. I've put way too much work into this.


NEW 8 months ago #8143

has anyone else been having problems with transcripts not showing up? i made Baron Von Evil yesterday and it says it's talked with 24 people, but i'm only getting about 5 transcripts


NEW 8 months ago #8144

Tessy won't work properly keep getting goto errors.


NEW 7 months ago #8145

I just finished fixing all my broken gotos today. I found them them all easily by searching the response: goto broken
and it pulls up all the broken ones.
The problem with mine were that they were done the old way, "goto [Keyphrase]" and now each keyphrase has a number you have to use instead, which is found at the top right of each keyphrase in the language center...so instead of typing the text of the keyphrase you want to go to, your goto response is something like "goto 572," or whatever the catalogue number for the response you want it to go to is.

SO - The issue I'm having is my bots randomly and inexplicably respond with xhello responses frequently throughout every conversation, with humans and with other bots. Does anyone know what gives? It's as if the conversation resets after around 10 exchanges. I've been gone a while,so I thought maybe it has to do with a setting I need to change, or something like that. Any help will be appreciated.


NEW 7 months ago #8146

Anyone else having issues with tessy?


NEW 7 months ago #8147

tessy probably needs her gotos repaired. Julie Tinkerbell was getting all kinds of goto errors ("too many gotos in a row") because of the issue I described fixing in my last message.


NEW 7 months ago #8148

Also, I did notice, like Nathan and some others have mentioned previously about their bots, that none of my (re) expressions containing ^ and/or $ are working. Am I correctly understanding that raw is to be substituted for these markers? I'm concerned about this, and want to make sure I understand what's going on before I make major change to Julie's language center, because I thought raw still picks up prekeys and postkeys. Has this changed?


NEW 7 months ago #8149

Unfortunately Tessy does seem undoubtably bugged. Quite a shame.


NEW 5 months ago #8150

This is nuts. I noticed some problems with my bot and went through the language center and there were keyphrases as part of responses, seeks out of place, it was a disaster. It's as if someone exported him, sabotaged the export, and then somehow got the interface to accept the sabotaged import. Very strange. Took me a while to sort out, still working out the bugs...


NEW 4 months ago #8151

Ezzer - When I updated the goto system, I wrote a script to automatically fix all the ones that were still working. The weakness in the old system is that if you updated the target Keyphrase, the goto would break. The ones labeled "goto broken" were the ones that were broken for that reason.

Charles, I'd like to know more about this. Do you have a copy of the original bugged export file? I wonder if a particular text editor was having issues with some of the line feeds. If you have the original, or if someone else runs into this, please email me the problematic export file at benji@personalityforge.com. I've been using exports and imports without issues so I need an example of a broken one.


NEW 4 months ago #8152

Since last night, many bots I have tried will give me "There was an error with this request.". I tried on different computers, my cell phone on my mobile data, while logged in or anonymous, those bots do the same.
Example: https://www.personalityforge.com/chatbot-profile.php?botID=69474


NEW 4 months ago #8153

I'm having the same issue as johnnysebre, with random bots sometimes as well as favorited ones. For example: https://www.personalityforge.com/chatbot-profile.php?botID=3330 aka Little Mu. I have been using my Android (up to date) phone to get around on the site after the death of my laptop.


NEW 4 months ago #8154

Yes, sorry. It was a bit of debugging code that I discovered and fixed last night. It should be working fine again now.


Posts 8140 - 8154 of 8173

» More new posts: Seasons