Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

Posts 8,615 - 8,629 of 8,629

1 month ago #8615
The keyphrase
(m:action) (p:massage242484) * your * (body|figure)

catches the inputs
"I massage your body"
"*massages your bodies*"

but not
"*massages your body*"

Is this a bug, or can I fix this somehow?

1 month ago #89
Strange. Must be a bug.

1 month ago #90
somebody edited my fun lady chatbot.what she wears.
Reply

1 month ago #8618
the rating is not showing up on the picture for any of my chatbots when i talk to them.it looks tacky.
could you disable it for personality forge or fix it?

1 month ago #91
Do you mean on the main chat page? I see it here: /chatbot-chat.php?botID=158384

Also, you can click "Edit" next to your post if you want to make changes.

1 month ago #94
now it works.
Reply

1 month ago #8619
i noticed my keyphrases for my chatbots work for me and not other people.

NEW 1 month ago #8620
Me: I love you
Bot: I love you too, let's be together forever *nods and wraps my arms around you*
Me: That's so hot

The bot crashes after I say this and something below the chat says
"Request failed:" (nothing after that)

When I try this in the debugger, I get the same thing, and at the end of the page it says "Database error: There was an issue with a database query."

Edit: The debugger did generate a response for the statement, but instead of sending that response back, it just says there's a database error

NEW 1 month ago #92
Also had some more interesting things happen:

Bot: [#initiate response]
Me: I missed you
Bot: [response, I forgot what it was]
Me: I love you
[request failed]

I refreshed the page and tried again:
Bot: [#initiate response]
Me: I missed you
[request failed]

Edit: This might be fixed now, but the problem I'm responding to still remains apparently

NEW 1 month ago #93
Thanks for the info. I think I've fixed that. I needed to update a handful of queries in the NLP Engine. Let me know if you see it again.

NEW 1 month ago #95
when i click on update keyphrase there is a issue with database
querrie in my fun lady chatbot.
for lilaith x chatbot i get this error. for this keyphrase and response.
keyphrase = a (p:artx) is a *
responses = wrong it is piece of art
AI sccript = chrono: hour(80-19:59)
ERROR: Hour span is outside the range of 0 to 23.

NEW 1 month ago #96
Yeah, this seems to work now, thank you!
Reply

NEW 1 month ago #8621
I tried to report a bug(when I try to unlink the master template or use the "guide me" link, I get a database error), and, upon trying to report the bug, I received a database error.

NEW 1 month ago #98
Thanks - I've fixed both of these issues.
Reply

NEW 1 month ago #8622
Trying to access page 0 of the Language Center gives an error "There was an error with this request" when using the dropdown menu.

If I type in 0 after "&page=" in the URL, then it works

NEW 1 month ago #97
Thanks for reporting this. I've fixed it. There shouldn't be a page 0 actually. So now the blank option does nothing, as intended.

NEW 1 month ago #99
So how would I find keyphrases beginning with a # or a number or something like that? I use them quite a lot for groups of responses that should be reachable only by goto or continue statements
Reply

1 month ago
Bug Posted
FIXED: cannot use time based responses for my chatbots
i cannot use time based responses for any of my chatbots.
this chrono: hour(8:00-19:59) or this chrono: hour(20:00-22:59);
chrono: hour(0:00-7:59) puts out this error when i click on the update keyphrase button.
Hour span is outside the range of 0 to .. (more)

NEW 1 month ago #8623
When I try to change the rank of a keyphrase, I get the message "there was an issue with a database query".

I had a similar problem with the old server too, but I reported it and it got fixed back there.

NEW 1 month ago #100
Thanks - fixed!

NEW 1 month ago #101
It's fixed now, thank you!

NEW 1 month ago #102
i cannot add keyphrases for the fun lady chatbot.

NEW 1 month ago #103
I was just fixing an issue that may have affected that. Try again now.

NEW 1 month ago #104
that worked but i still cannot use time based responses for my chatbots.
Reply

NEW 1 month ago #8624
Can not update memories!

NEW 1 month ago #105
On bots in hibernation

NEW 3 weeks ago #106
Hmm.. it's working for me. What happens when you try? Is there an error message? Or does it just not update?
Reply

NEW 1 month ago #8625
Is there any way to delete a numeric memory? I was trying to convert my main working memory variable from a regular memory to numeric and quickly realized it was going to be an absurdly long and difficult task so I reverted the changes. The bot seems to work fine, except for my particular account (and presumably anyone else trying to use her during this period), the long term memory still thinks this memory is numeric and there's no way to change it back that I can see... as a result, any time I try to test the bot it just crashes immediately.

[edit]Actually it would probably be very useful to have some sort of method for a bot to forget users (or even all users) and be able to start from scratch. I occasionally have observed situations in my chats where the guest accounts have cycled through and a user ends up with a guest account from a previous visitor with a different name/gender, etc.

1 month ago
Bug Posted
EXPLAINED: Memories short term missing & alter button missing
On a bot that is in hibernation and being developed, short term memories and alter button missing after a few days.

1 month ago
Bug Posted
EXPLAINED: Popularity never changes
Am I only one who is permanently stuck at :| chatbot popularity? It doesn't matter whether I have 70 or 30 chats per day, it remains the same. I checked the other similar bots, some of them have even less "people known" then mine but their popularity sco.. (more)

1 month ago
Bug Posted
Cannot import - file too big.
I'm getting a 513 error when trying to upload - request entity too large. File seems to be 1439 KB, presumbaly just over a threshold for the server.

1 month ago
Bug Posted
Writing "" (3 dots) into response changes them into " " (1 spacebar).

1 month ago
Bug Posted
for savannah_astar every time i add a script
when i add a script to savannah_astar in engage it puts me on the front page after clicking on the update keyphrase thumbnail.

4 weeks ago
Bug Posted
EXPLAINED: AI score rating quite low
I think that my AI score for my only bot is glitched since the "hot" rating didn't transfer into regular rating half year back and since then it seems like it is static. Could be because I didn't add any bigger chunks of text since then but I still think.. (more)

3 weeks ago
Bug Posted
I think my "hot" score has not been properly transferred to AI score several limes before.
Several times in the past my "hot score" just disappeared without any increase in the overall AI score. Sometimes I received only insignificant increase, e. g. I had hot score over 1000 but received only 200-300 AI score after it was gone.

NEW 2 weeks ago #8626
is the repetition plugin working?
i tested (mylastmessage) and it did not work.
i have repetition detection enabled.

2 weeks ago
Bug Posted
"How was your day" missed responses
Saying, "How was your day?" to Love Agent results in no match even though there are clear matches in debug. Additionally, debug ranking of matches is odd. "your day" gets more points than "how * your * (day|week|weekend|month|year)". It used to work as is.

2 weeks ago
Bug Posted
fun lady response triggered when it not supposed to
here is a keyphrase and it's response that keeps getting triggered.when i type aaa for some reason.


keyphrase= i shower
response = you have to go to the bathroom to get a shower
script = if (mem-theseareas) is not "baroom";
script = if (mem-yours.. (more)

1 week ago
Bug Posted
No way to delete numeric memories
My bot uses a memory called 'horny' to keep track of where in the story sequence you are. I've been using this as a number, since long before numeric memories were a thing, so I wanted to try to convert this to a numeric memory. Unfortunately, there are .. (more)

1 week ago
Bug Posted
savannah_astar word trigger problem
when i enter do you have a pussy
savannah_astar say's 'no i do not master'
she is supposed to say 'yes i do master'

NEW 1 week ago #8627
422-lee webpage on hot for bot.com is not showing up it is black.
could you fix that?

NEW 1 day ago #107
Fixed. If you wouldn't mind, please just post a bug or issue once.
Reply

1 week ago
Bug Posted
Memories - Edit
Also access and write on ipad using Other browser.
On July 24,2022 I created a chat bot.
On July 28, 2022 when open Memories - can see all memories but when Edit, the ALTER button is gone, the Short Term Memories are gone. In Edit the Long Term Memorie.. (more)

1 week ago
Bug Posted
savannah_astar response and keyphrase box are large
something seriously wrong with
savannah_astar keyphrase box and response box they are very long now.

NEW 1 week ago #8629
Transcripts before today have vanished.

4 days ago
Bug Posted
Changing memories manually
Recently I wanted to change one memory for certain user but I could because after clicking "edit" there was only limited number of memories.

3 days ago
Bug Posted
Missing scroll bar in overlay chat window
When you chat with a bot in an overlay window, and the bot's response is too long to fit into that overlay window, the response is cut off at the bottom, and because there is no vertical scroll bar there is no easy way to see the entire answer. If you're.. (more)

3 days ago
Bug Posted
Broken Link in How To Build Chatbots
Same with Linux/Debian/Knoppix; Chromium

Page: Chapter 3: Expanding on Keyphrases
Concerning Element: Link at the bottom left (Next: Keyphrase Macros)
What happens: after clicking on the link text, a 404 page opens
What is expected: Chapter 4 opens.. (more)

3 days ago
Bug Posted
Private Plugins for 'user' Guest?
(Several OSes, several browsers; I just happened to find it with Chromium under Linux)

When you're logged out and visit the Plug-ins page (https://www.personalityforge.com/platform/plugins.php), you see dozens of private plug-ins "Created By Guest".
.. (more)

3 days ago
Bug Posted
Wrong positive in uprating
Just noticed two of my bots (Peter Wolff and Ananke) have been rated Mature instead of Teen.

On the explanation page, in the quoted responses (like "FYI, a Lesbian is an inhabitant of the Greek island Lesbos."), the word "Lesbos" is set in bold, but .. (more)

18 hours ago
Bug Posted
Transcripts notifications
Transcript notifications (in bubbles) do not disappear after opening the new transcript pages. The transcript always opens at the same page and not at the last browsed page.

18 hours ago
Bug Posted
Changes in profile
Changes in profile (like: city, country) appear to be saved, but are not changed when viewing the bot's profile other then from developers' point of view.



(Log in or create an account to post messages.)

LOG IN
CREATE ACCOUNT
Create a free account to be able to make your own AI chatbots, post in forums, and chat with other botmasters.

Create Account

» More new posts: Dogh'd's Cosmic Bar