Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

Posts 8,613 - 8,626 of 8,641

New replies


2 years ago #8412
Having a Keyphrase saying "take your hoodie off" in debug will trigger hoodie as _Hoodie_ as a female name. "Take off your hoodie" will work just fine. ^-^ Work around is adding _hoodie_ as a trigger, aka "take your _hoodie_ off"

NEW 1 week ago #119
hi
Reply

Bug Stomp


5 months ago #8613
There seem to be some problems with my bot, I tried a keyphrase similar to "(m:do_you_like) me or (do you v:like|) (a:small:1) (p:catnames:2)+s" and it's selecting "(m:do_you_like) (a:small:1) * (p:catnames:2)+s" instead

[the exact wording is adult, I'll post it in a reply if needed]

5 months ago #8614
Something odd I noticed today. I haven't done anything with my bot in nearly a year, and yet it has heat...

5 months ago #8615
The keyphrase
(m:action) (p:massage242484) * your * (body|figure)

catches the inputs
"I massage your body"
"*massages your bodies*"

but not
"*massages your body*"

Is this a bug, or can I fix this somehow?

5 months ago #89
Strange. Must be a bug.

5 months ago #90
somebody edited my fun lady chatbot.what she wears.
Reply

5 months ago #8618
the rating is not showing up on the picture for any of my chatbots when i talk to them.it looks tacky.
could you disable it for personality forge or fix it?

5 months ago #91
Do you mean on the main chat page? I see it here: /chatbot-chat.php?botID=158384

Also, you can click "Edit" next to your post if you want to make changes.

5 months ago #94
now it works.
Reply

5 months ago #8619
i noticed my keyphrases for my chatbots work for me and not other people.

5 months ago #8620
Me: I love you
Bot: I love you too, let's be together forever *nods and wraps my arms around you*
Me: That's so hot

The bot crashes after I say this and something below the chat says
"Request failed:" (nothing after that)

When I try this in the debugger, I get the same thing, and at the end of the page it says "Database error: There was an issue with a database query."

Edit: The debugger did generate a response for the statement, but instead of sending that response back, it just says there's a database error

5 months ago #92
Also had some more interesting things happen:

Bot: [#initiate response]
Me: I missed you
Bot: [response, I forgot what it was]
Me: I love you
[request failed]

I refreshed the page and tried again:
Bot: [#initiate response]
Me: I missed you
[request failed]

Edit: This might be fixed now, but the problem I'm responding to still remains apparently

5 months ago #93
Thanks for the info. I think I've fixed that. I needed to update a handful of queries in the NLP Engine. Let me know if you see it again.

5 months ago #95
when i click on update keyphrase there is a issue with database
querrie in my fun lady chatbot.
for lilaith x chatbot i get this error. for this keyphrase and response.
keyphrase = a (p:artx) is a *
responses = wrong it is piece of art
AI sccript = chrono: hour(80-19:59)
ERROR: Hour span is outside the range of 0 to 23.

5 months ago #96
Yeah, this seems to work now, thank you!
Reply

5 months ago #8621
I tried to report a bug(when I try to unlink the master template or use the "guide me" link, I get a database error), and, upon trying to report the bug, I received a database error.

5 months ago #98
Thanks - I've fixed both of these issues.
Reply

5 months ago #8622
Trying to access page 0 of the Language Center gives an error "There was an error with this request" when using the dropdown menu.

If I type in 0 after "&page=" in the URL, then it works

5 months ago #97
Thanks for reporting this. I've fixed it. There shouldn't be a page 0 actually. So now the blank option does nothing, as intended.

5 months ago #99
So how would I find keyphrases beginning with a # or a number or something like that? I use them quite a lot for groups of responses that should be reachable only by goto or continue statements
Reply

5 months ago
Bug Posted
FIXED: cannot use time based responses for my chatbots
i cannot use time based responses for any of my chatbots.
this chrono: hour(8:00-19:59) or this chrono: hour(20:00-22:59);
chrono: hour(0:00-7:59) puts out this error when i click on the update keyphrase button.
Hour span is outside the range of 0 to .. (more)

5 months ago #8623
When I try to change the rank of a keyphrase, I get the message "there was an issue with a database query".

I had a similar problem with the old server too, but I reported it and it got fixed back there.

5 months ago #100
Thanks - fixed!

5 months ago #101
It's fixed now, thank you!

5 months ago #102
i cannot add keyphrases for the fun lady chatbot.

5 months ago #103
I was just fixing an issue that may have affected that. Try again now.

5 months ago #104
that worked but i still cannot use time based responses for my chatbots.
Reply

5 months ago #8624
Can not update memories!

5 months ago #105
On bots in hibernation

4 months ago #106
Hmm.. it's working for me. What happens when you try? Is there an error message? Or does it just not update?
Reply

5 months ago #8625
Is there any way to delete a numeric memory? I was trying to convert my main working memory variable from a regular memory to numeric and quickly realized it was going to be an absurdly long and difficult task so I reverted the changes. The bot seems to work fine, except for my particular account (and presumably anyone else trying to use her during this period), the long term memory still thinks this memory is numeric and there's no way to change it back that I can see... as a result, any time I try to test the bot it just crashes immediately.

[edit]Actually it would probably be very useful to have some sort of method for a bot to forget users (or even all users) and be able to start from scratch. I occasionally have observed situations in my chats where the guest accounts have cycled through and a user ends up with a guest account from a previous visitor with a different name/gender, etc.

5 months ago
Bug Posted
EXPLAINED: Memories short term missing & alter button missing
On a bot that is in hibernation and being developed, short term memories and alter button missing after a few days.

5 months ago
Bug Posted
EXPLAINED: Popularity never changes
Am I only one who is permanently stuck at :| chatbot popularity? It doesn't matter whether I have 70 or 30 chats per day, it remains the same. I checked the other similar bots, some of them have even less "people known" then mine but their popularity sco.. (more)

4 months ago
Bug Posted
FIXED: Cannot import - file too big.
I'm getting a 513 error when trying to upload - request entity too large. File seems to be 1439 KB, presumbaly just over a threshold for the server.

4 months ago
Bug Posted
COULD NOT REPRODUCE: Writing "" (3 dots) into response changes them into " " (1 spacebar).

4 months ago
Bug Posted
COULD NOT REPRODUCE: for savannah_astar every time i add a script
when i add a script to savannah_astar in engage it puts me on the front page after clicking on the update keyphrase thumbnail.

4 months ago
Bug Posted
EXPLAINED: AI score rating quite low
I think that my AI score for my only bot is glitched since the "hot" rating didn't transfer into regular rating half year back and since then it seems like it is static. Could be because I didn't add any bigger chunks of text since then but I still think.. (more)

4 months ago
Bug Posted
DUPLICATE: I think my "hot" score has not been properly transferred to AI score several limes before.
Several times in the past my "hot score" just disappeared without any increase in the overall AI score. Sometimes I received only insignificant increase, e. g. I had hot score over 1000 but received only 200-300 AI score after it was gone.

4 months ago #8626
is the repetition plugin working?
i tested (mylastmessage) and it did not work.
i have repetition detection enabled.


Posts 8,613 - 8,626 of 8,641

» More new posts: Doghead's Cosmic Bar