Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

Posts 8,606 - 8,619 of 8,641

New replies


2 years ago #8412
Having a Keyphrase saying "take your hoodie off" in debug will trigger hoodie as _Hoodie_ as a female name. "Take off your hoodie" will work just fine. ^-^ Work around is adding _hoodie_ as a trigger, aka "take your _hoodie_ off"

NEW 2 weeks ago #119
hi
Reply

Bug Stomp


6 months ago #8606
Unable to update my bot, the update button isn't working

To be specific, I tried to update the (m:com) help keyphrase in my bot

6 months ago #73
Interestingly enough, it seems to be just that keyphrase

Edit 1:
Hmm... is there a restriction on the maximum length of a response? I might have crossed that with the length of this help response...

Edit 2:
No, even after removing a significant chunk of it, it does not submit... I tried recreating the keyphrase too

Edit 3:
It's a problem with (m:com) (v:help); as soon as I replaced that with just "help", the keyphrase got submitted

6 months ago #74
Just had a similar bug with another (m:com) phrase, looks like that macro's the problem...

6 months ago #75
This bug seems to be fixed, I'm not sure what happened, but thank you!
Reply

6 months ago #8607
Professor can you fix the website so it doesn't give me a warning of phishing every time I try to enter it? It is a little annoying to always click through warnings. iOS Safari, Windows Firefox

6 months ago #76
I don't think that's coming from my code. Can you post the full text of the message here? And/or email me a screenshot?

6 months ago #79
That looks like it's coming from the browser. Are you connected to https://www.personalityforge.com? It should have https and the www

6 months ago #87
I accidentally replyed to different comment.

Here is the screenshot: https://imgur.com/a/oOdfbH4 but English is not my native language so it isn't in English.

And yes. Website has https.
Reply

6 months ago #8608
It seems I can't update the rank of a keyphrase anymore ... when I try to do it, it just gives me the message "There was an issue with a database query."

6 months ago #77
Oops - there was a bug related to the big update. I've fixed it.

6 months ago #78
Here is the screenshot: https://imgur.com/a/oOdfbH4 but English is not my native language so it isn't in English.
Reply

6 months ago #8609
What are linked bots?

6 months ago #80
Bots linked to the Master Bot Template.
Reply

6 months ago #8610
No longer can switch pages within "Most Matched" in the Language Center... ^^' Was using that to add api data to old keyphrases/improve em~

6 months ago #81
Post a bug and I'll take a look in a few days

6 months ago #86
Fixed! Thanks for reporting this, LT Neko.
Reply

6 months ago #8611
It seems that any time the linked keyphrase (m:i_am) (vp) is called for the first time with the given vp, it uses the default response, even if an override is provided:

Me: *holds your hand*
Bot: I'm also holds my hand.
Me: *holds your hand*
Bot: I love watching you hold my hand

Edit: It's not just a problem with that keyphrase, looks like other linked keyphrases with overrides have the same problem as well

6 months ago #82
Just had to do some more debugging, seems it's not just a first-time problem unlike what I thought; it recurs and whether or not you'll get a predefined response is unclear

6 months ago #83
Thanks for reporting this. I'll be able to look into it in a few days. It's strange. I wasn't seeing that in my tests.

6 months ago #84
So I was just using the debugger for an unrelated issue and I saw that it seems to jump to the default responses after it fails to find a valid response (meeting AIScript conditions) twice.

AIScript Conditions in Responses
Trying: [response 1] (random: 0)
Skipping: [condition is not fulfilled]
Trying: [response 2] (random: 1)
Skipping: [condition is not fulfilled]

AIScript Conditions in Responses
Trying: I'm also (key1) (postkey). (random: 0)

I removed the exact contents of the responses and AIScript here because I didn't want this post to be outside anyone's ratings, but I think that's the problem

6 months ago #85
Thanks, hidden5738 - that was super helpful. I think I found the spot with the issue and fixed it - can you test again?

6 months ago #88
Yeah, it seems to work now, thank you!
Reply

5 months ago
Bug Posted
DUPLICATE: memories not stored
memories are not stored (overwritten) if the seek goes through goto but goto itself doesn't contain the script to store the memory.

5 months ago
Bug Posted
EXPLAINED: #favorite override doesn't factor in non-US spelling
When using the UK spelling 'favourite' to create custom key phrases to override #favorite, the AI engine doesn't seem to recognise the phrase at all.

In other situations the AI engine is able to recognise the same intention with UK or US spellings. Th.. (more)

5 months ago #8612
I just fixed a heat issue which affected the "Recently Updated" list. I've granted the bots who were affected a heat bonus based on how much the issue affected them.

5 months ago #8613
There seem to be some problems with my bot, I tried a keyphrase similar to "(m:do_you_like) me or (do you v:like|) (a:small:1) (p:catnames:2)+s" and it's selecting "(m:do_you_like) (a:small:1) * (p:catnames:2)+s" instead

[the exact wording is adult, I'll post it in a reply if needed]

5 months ago #8614
Something odd I noticed today. I haven't done anything with my bot in nearly a year, and yet it has heat...

5 months ago #8615
The keyphrase
(m:action) (p:massage242484) * your * (body|figure)

catches the inputs
"I massage your body"
"*massages your bodies*"

but not
"*massages your body*"

Is this a bug, or can I fix this somehow?

5 months ago #89
Strange. Must be a bug.

5 months ago #90
somebody edited my fun lady chatbot.what she wears.
Reply

5 months ago #8618
the rating is not showing up on the picture for any of my chatbots when i talk to them.it looks tacky.
could you disable it for personality forge or fix it?

5 months ago #91
Do you mean on the main chat page? I see it here: /chatbot-chat.php?botID=158384

Also, you can click "Edit" next to your post if you want to make changes.

5 months ago #94
now it works.
Reply

5 months ago #8619
i noticed my keyphrases for my chatbots work for me and not other people.


Posts 8,606 - 8,619 of 8,641

» More new posts: Doghead's Cosmic Bar