Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

Posts 8,600 - 8,611 of 8,625

1 month ago #8600
Is anyone else having problems with their bot's AI rating not changing? My bot has a tonne of keyphrases and responses by now, but it's rating is still 0

1 month ago #62
I just fixed an issue that was preventing a bot's AI from updating yesterday. It should be back to updating overnight.

1 month ago #64
Yeah it works now, thank you!
Reply

1 month ago
Bug Posted
FIXED: Unable to view adult content
In my account, I have set my "approved ratings" to "allow teen and mature", however, I still have some problems with ratings:

1. When I try to access some plugins (eg: https://www.personalityforge.com/platform/plugin-view.php?pluginID=6999), it tells .. (more)

1 month ago #8601
Sometimes my phrase "*" overwrites other keyphrases, despite not having any available seeks. It took me a while to figure it out so I decreased its rating to -150 however, the problem is that I want it to overwrite any other responses, but only when there are available seeks. I used this for insisting on apology when user is "dumped" but it doesn't seems to work anymore because it triggers #engage (I think) when there are not valid seeks, overwriting any other responses.

1 month ago #65
* isn't meant to be a Keyphrase or Seek. As a Keyphrase, that's what #engage is for, and as a Seek, that's what #nomatch is for.
Reply

1 month ago
Bug Posted
EXPLAINED: Comfort
Comfort on my bot fell from 4 :) to 3 :) without any apparent reason.

1 month ago #8602
It used to work. What keyword can I use to catch every phrase but not overwrite other if there is not proper seek available?
HIDDEN: Post content outside ratings limits.

1 month ago #66
Not sure if you were replying to me but, I just used to have a simple cycle when the user pissed my bot too much. This cycle has been triggered no matter what user typed (hence *) until the user apologized which threw him out of cycle. It doesn't work anymore because the phrase is triggered even when there are no valid seeks (when the bot has not been pissed) and it triggers #engage instead.
Reply

1 month ago #8604
Numeric Memories
1. When I set a number by default in Initialize - number is in Long Term Memory
2. When I set numbers, or add etc., in Response or Keyphrase, the number is on in SelfMemories.

1 month ago #67
Now working but when click on Edit for Long-Term Memories the field is blank.

1 month ago #68
i keep getting this error on multiple webpage i go to.

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics
ERR_CONNECTION_TIMED_OUT
Reply

1 month ago #8605
hot for bot.com is greyed out and i cannot interact with any chatbots.

1 month ago #69
Same thing happened to me on PF when logged out

I had to hit F12, then delete the div#modalOverlay in the dev console of my browser

After that only could I login

1 month ago #70
i found out i had to use the front page to enter hot for bot websight.normaly i do not have to do that.

1 month ago #71
Well whatever the problem was it seems to be fixed now

1 month ago #72
okay
Reply

1 month ago #8606
Unable to update my bot, the update button isn't working

To be specific, I tried to update the (m:com) help keyphrase in my bot

1 month ago #73
Interestingly enough, it seems to be just that keyphrase

Edit 1:
Hmm... is there a restriction on the maximum length of a response? I might have crossed that with the length of this help response...

Edit 2:
No, even after removing a significant chunk of it, it does not submit... I tried recreating the keyphrase too

Edit 3:
It's a problem with (m:com) (v:help); as soon as I replaced that with just "help", the keyphrase got submitted

1 month ago #74
Just had a similar bug with another (m:com) phrase, looks like that macro's the problem...

1 month ago #75
This bug seems to be fixed, I'm not sure what happened, but thank you!
Reply

1 month ago #8607
Professor can you fix the website so it doesn't give me a warning of phishing every time I try to enter it? It is a little annoying to always click through warnings. iOS Safari, Windows Firefox

3 weeks ago #76
I don't think that's coming from my code. Can you post the full text of the message here? And/or email me a screenshot?

3 weeks ago #79
That looks like it's coming from the browser. Are you connected to https://www.personalityforge.com? It should have https and the www

3 weeks ago #87
I accidentally replyed to different comment.

Here is the screenshot: https://imgur.com/a/oOdfbH4 but English is not my native language so it isn't in English.

And yes. Website has https.
Reply

4 weeks ago #8608
It seems I can't update the rank of a keyphrase anymore ... when I try to do it, it just gives me the message "There was an issue with a database query."

3 weeks ago #77
Oops - there was a bug related to the big update. I've fixed it.

3 weeks ago #78
Here is the screenshot: https://imgur.com/a/oOdfbH4 but English is not my native language so it isn't in English.
Reply

3 weeks ago #8609
What are linked bots?

3 weeks ago #80
Bots linked to the Master Bot Template.
Reply

3 weeks ago #8610
No longer can switch pages within "Most Matched" in the Language Center... ^^' Was using that to add api data to old keyphrases/improve em~

3 weeks ago #81
Post a bug and I'll take a look in a few days

3 weeks ago #86
Fixed! Thanks for reporting this, LT Neko.
Reply

3 weeks ago #8611
It seems that any time the linked keyphrase (m:i_am) (vp) is called for the first time with the given vp, it uses the default response, even if an override is provided:

Me: *holds your hand*
Bot: I'm also holds my hand.
Me: *holds your hand*
Bot: I love watching you hold my hand

Edit: It's not just a problem with that keyphrase, looks like other linked keyphrases with overrides have the same problem as well

3 weeks ago #82
Just had to do some more debugging, seems it's not just a first-time problem unlike what I thought; it recurs and whether or not you'll get a predefined response is unclear

3 weeks ago #83
Thanks for reporting this. I'll be able to look into it in a few days. It's strange. I wasn't seeing that in my tests.

3 weeks ago #84
So I was just using the debugger for an unrelated issue and I saw that it seems to jump to the default responses after it fails to find a valid response (meeting AIScript conditions) twice.

AIScript Conditions in Responses
Trying: [response 1] (random: 0)
Skipping: [condition is not fulfilled]
Trying: [response 2] (random: 1)
Skipping: [condition is not fulfilled]

AIScript Conditions in Responses
Trying: I'm also (key1) (postkey). (random: 0)

I removed the exact contents of the responses and AIScript here because I didn't want this post to be outside anyone's ratings, but I think that's the problem

3 weeks ago #85
Thanks, hidden5738 - that was super helpful. I think I found the spot with the issue and fixed it - can you test again?

3 weeks ago #88
Yeah, it seems to work now, thank you!
Reply


Posts 8,600 - 8,611 of 8,625

» More new posts: Dogh'd's Cosmic Bar