Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

8496 - 8510 of 8529


NEW 7 months ago #8496

Okay, so it turns out that the last part of the message that those seeks were hanging off is what was triggering those responses. My next question is why is that bit matching? I've tweaked the wording and it's no longer matching, but that's literally all I've tweaked.


NEW 7 months ago #8497

I'm not totally sure, but from what I understand and remember (disclaimer yada yada), the previous output stays in memory, so if your bot asks "where do you want to f* me?", and the users only uses a one-word answer, the AI tries to make a sentence, which should result in something like "I want to f* you in your mouth", which matches both seeks, but even though "mouth" with 5 letters is a better match than the other 4 letter word, the seek with the f-word in itself is much higher ranked by its size, so it outweighs the mouth. This always gets tricky if you have words from the seeks in your previous output.


NEW 7 months ago #8498

time based responses for intitiate are not showing for skyla grey chatbot.
test it if you do not believe me.


NEW 6 months ago #8499

I'm having trouble figuring out what I'm doing wrong with self memories. So this works:
Response- "I'm wearing a (self-top)."
AI Script- self: rem "(pluginname)" as only "top";
But if I try to change the word "top" to anything else it doesn't work. It won't let me have it as (self-shirt) even if I write the script as self: rem "(pluginname)" as only "shirt". What am I doing wrong?


NEW 6 months ago #8500

Testme, I wouldn't use self memories for clothing. Self memories are shared across all users, as I understand it; "It contains memories that your chatbot can access no matter who your chatbot is chatting with." So use for stuff the bot likes or dislikes, or that you wouldn't expect a user to change. I'm not a big user of self memories, myself, though my bot is an unashamedly not very botish pseudo-cyoa for sex.

That said, can't see issues with your statements. Does it work fine with regular memories?


NEW 6 months ago #8501

i think testme is trying to store a randomly selected clothing word from a plugin so that it can be retrieved for latter use.
that is a great idea.
i never knew it could be done.


NEW 6 months ago #8502

@Bobstack Trying. It looks like it should be able to be done according to Book of AI in memories.

@Maryguise- Thank you, I had no idea self memories worked like that, yeah def not what I want then. So I tried it as a regular memory and I'm pretty much getting the same results. This worked:
Response- "I'm wearing (mem-top)."
AIScript- rem "(pluginname)" as only "top"

But again if I change the word 'top' to anything else, it won't work for some reason. And yes, I am making sure to change 'top' in both script and response. I have 9 different plugins I'm trying to recall upon when needed and so far I can only remember my 'top' and 'myrace' for ethnicity and appearance. No other words seem to work for me and it's driving me nuts.


NEW 6 months ago #8503

I just tried the 'myrace' one as a normal memory too, and now that one doesn't work. Which is all the more weird cause it worked as a self-mem before. The 'top' is the only one I can get to work as a normal mem.


NEW 6 months ago #8504

you probably could reuse scripts how they are to do other things.


NEW 6 months ago #8505

@Bobstack
Are we limited to how many different memories we can create? I tried your suggestion and reused another script I made and it worked. But that doesn't solve my problem cause now that implies that I can't make any new memories. To which I just tried something else and it seems I may be right.
I did this test just to see if it would let me make a new memory-
Response: 'lets play hide and seek'
AI Script: rem "hide" as only "play"
Seek Response: *hides*
AI Script: if (mem-hide) is "play"

Anyway this didn't work and here's what the debugger said:
Trying: *hides* (random: 0)
Skipping: (mem-hide) does not exist.


NEW 6 months ago #8506

@testme,

You are reading the memory backwards. When you write rem "hide" as only "play", you are storing the memory "hide" inside the box labelled "play". To recall that memory, you need to do open the play box and look for the hide memory: "if (mem-play) is "hide".

[edit]Likely this is the same issue with all of your other memory-related problems.


NEW 6 months ago #8507

@Emily Thank you so much!!! Everything I was trying to do works perfectly now!


NEW 6 months ago #8508

Is there any way to fiddle with the plugins that handle the various 'yes', 'no' cases? The expression 'No problem' gets interpreted to mean 'no', when it really probably ought to go to 'yes', if anything. Is there any way to get this to work correctly other than adding 'no problem' to every seek that looks for 'yes'?


NEW 6 months ago #8509

i am (woman|female) keyphrase not working


NEW 5 months ago #8510

this plugin (p:adult-female) is not working completely.
could someone test it out?


Posts 8496 - 8510 of 8529

» More new posts: Seasons