Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

8488 - 8502 of 8511


NEW 2 months ago #8488

Bobstack, a seek only firing for you and not others implies it's related to memories not set, in my experience, though could be something with happiness. Does your go to sleep seek/KP/response have any memories referenced in the aiscript or the text? Are all of those initialized or certainly set beforehand? I had something similar when I botched initialization of memories due to working offline (why the flip that line has to have no escape characters, but they can be used - and I'm sure at one point had to be - elsewhere is a mystery).


NEW 2 months ago #8489

i found out that i had set the responses for a certain time.
so i added more responses to be triggered to the times i did not have responses for.


NEW 2 months ago #8490

my scripts for storing long term memories have stopped working.
one of them for the settings is default "blank" as "goodbye"
it is used to change the introductory saying to a different saying.


NEW 2 months ago #8491

for hello urt the succubus chatbot says i have too many gotos in a row


NEW 2 months ago #8492

That's generally a problem of not having any valid responses. Like when you have a 'if' statement but no memory set to trigger it.


NEW 2 months ago #8493

that is supposed to be handled by xhello but it is not anymore.


NEW 2 months ago #8494

Having these two keyphrases

Keyphrase 1:
(my name is|call me) *

Response:
"I'll call you (mem-name):
AIscript: rem (postkey) as only "name"

Keyphrase 2:
my * name (is not|isn't) *
AIscript: rem (name) as only "name"

Response:
"Oh, then what should I call you?" (Hanging question)




Normally if a user responds with anything like Lily/Bean/Tom/Jessy ect it'll trigger the 1st keyphrase, though if the 2nd keyphrase's has a number in its response, it'll completely negate the auto pickup to the first keyphrase. ^-^

For example:

"Oh, then what should I call you? :3 "

Registers the number as the hanging question~


NEW 2 months ago #8495

I have an odd bug. With the two seeks:
+ (mouth|blowjob|bj|deepthroat|oral|throat)
+ (ass|anal|arse|bottom|bum|bugger|bumhole|arsehole|asshole|butthole|asshole|sex|fuck)

These two are hanging off the same prior seek (with another as well). When the bot is being used, typing 'mouth' at that point matches the first... then matches the second with higher accuracy and pulls that in. Any suggestions for what could be the issue here? (the plus signs are because it's from working offline, and are to denote tha they're seeks). No AIScript attached to either; the latter has as a response a goto, unlike the former, but that shouldn't matter. 'Mouth' should surely only trigger one of these??


NEW 2 months ago #8496

Okay, so it turns out that the last part of the message that those seeks were hanging off is what was triggering those responses. My next question is why is that bit matching? I've tweaked the wording and it's no longer matching, but that's literally all I've tweaked.


NEW 1 month ago #8497

I'm not totally sure, but from what I understand and remember (disclaimer yada yada), the previous output stays in memory, so if your bot asks "where do you want to f* me?", and the users only uses a one-word answer, the AI tries to make a sentence, which should result in something like "I want to f* you in your mouth", which matches both seeks, but even though "mouth" with 5 letters is a better match than the other 4 letter word, the seek with the f-word in itself is much higher ranked by its size, so it outweighs the mouth. This always gets tricky if you have words from the seeks in your previous output.


NEW 1 month ago #8498

time based responses for intitiate are not showing for skyla grey chatbot.
test it if you do not believe me.


NEW 3 weeks ago #8499

I'm having trouble figuring out what I'm doing wrong with self memories. So this works:
Response- "I'm wearing a (self-top)."
AI Script- self: rem "(pluginname)" as only "top";
But if I try to change the word "top" to anything else it doesn't work. It won't let me have it as (self-shirt) even if I write the script as self: rem "(pluginname)" as only "shirt". What am I doing wrong?


NEW 3 weeks ago #8500

Testme, I wouldn't use self memories for clothing. Self memories are shared across all users, as I understand it; "It contains memories that your chatbot can access no matter who your chatbot is chatting with." So use for stuff the bot likes or dislikes, or that you wouldn't expect a user to change. I'm not a big user of self memories, myself, though my bot is an unashamedly not very botish pseudo-cyoa for sex.

That said, can't see issues with your statements. Does it work fine with regular memories?


NEW 3 weeks ago #8501

i think testme is trying to store a randomly selected clothing word from a plugin so that it can be retrieved for latter use.
that is a great idea.
i never knew it could be done.


NEW 3 weeks ago #8502

@Bobstack Trying. It looks like it should be able to be done according to Book of AI in memories.

@Maryguise- Thank you, I had no idea self memories worked like that, yeah def not what I want then. So I tried it as a regular memory and I'm pretty much getting the same results. This worked:
Response- "I'm wearing (mem-top)."
AIScript- rem "(pluginname)" as only "top"

But again if I change the word 'top' to anything else, it won't work for some reason. And yes, I am making sure to change 'top' in both script and response. I have 9 different plugins I'm trying to recall upon when needed and so far I can only remember my 'top' and 'myrace' for ethnicity and appearance. No other words seem to work for me and it's driving me nuts.


Posts 8488 - 8502 of 8511

» More new posts: Seasons