Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

8356 - 8370 of 8468

NEW 1 year ago #8356

Could just be that the websites health isn't too great these days. Seems slow, with a lot of time-outs. I find I have to hit the button to submit new kp's more than once before it goes.

NEW 1 year ago #8357

I just tried out how you have it set up on your bot Zeig. (Thanks for checking it out) What I found is it has the same problem when I tried something similar to that. It will catch if the user uses A but not An.

I.E. I'm studying to be a engineer will catch
But I'm studying to be an engineer won't.

Though I love that yours returns the right determiner.

What I think I'm going to do is split it up into two different keyphrases. One for An and one for A.

NEW 1 year ago #8358

I found a way to fix it!

Here's a couple things I learned along the way.

I am a * (p:Job-catch) will return the correct determiner but it won't catch if the user inputs an. Such as "I am an engineer."

Where it gets weird is... I am a * (p:Job-catch), I am an * (p:Job-catch) won't accept an input of an either.

I am (a|an) * (p:Job-catch) on the other hand works perfectly. It accepts a or an. It will grab things like 'I am a heart surgeon', I am a brain surgeon' I am an English Teacher, electrical engineer... etc. and it doesn't accept nonsense such a I am a walrus.

Input: I am an electrical engineer
Response: 'Oh yeah?' She asks. 'Do you like being an engineer?' "

What I discovered about the above keyphrase I was working on that the problem appeared to be in the response. I'm starting to think it had something to do with the quotation marks.

When I changed the response to 'Oh yeah? Do you think you'll like being a (key5)?' Everything worked out perfectly. Right determiner given back. Doesn't accept garbage input.

Hopefully this little adventure will help someone in the future.

NEW 1 year ago #8359

I find I have to hit the button to submit new kp's more than once before it goes.

the same thing happens to me.

NEW 1 year ago #8360

Nice work, Nathan!

NEW 1 year ago #8361

urt the chatbot is not working.when other people talk to her.but her keyphrases only work with me.i do not think those people are chatbots.

NEW 1 year ago #8362

xnones are not working with story telling mode.

NEW 1 year ago #8363

I put once script on it and that is probably why it is not working for me

for urt chatbot.

NEW 1 year ago #8364

It looks like all bot conversations are no longer working due to an expired security certificate.

"This server could not prove that it is www.personalityforge.com; its security certificate expired yesterday. This may be caused by a misconfiguration or an attacker intercepting your connection. Your computer's clock is currently set to Sunday, May 5, 2019. Does that look right? If not, you should correct your system's clock and then refresh this page."

NEW 1 year ago #8365

my clock is right.

NEW 1 year ago #8366

Looks like this got fixed!

NEW 1 year ago #8367

Yes it's fixed

NEW 1 year ago #8368

Since a few days the keyphrases beginning with a Y dont show up in the language center interface any more ??!! To see or edit them I have to export and import the language center. The bug report doesn't' work any longer, so I come here to see if someone had a similar problem and solved it.

NEW 1 year ago #8369

Hi @Coffeebreak130, keyphrases beginning with Y (and all the others) are showing up fine for me. You might want to try clearing the cache on your browser or try an incognito/private window in your browser.

NEW 1 year ago #8370

I deleted all the browser memories except the cookies but that didn't help. It is not a cookie problem because I have the same problem with all my browsers. A private connection didn't help either. The same result when I import the language center again. I hope they will come back the same way as they disappeared mysteriously.

Posts 8356 - 8370 of 8468

» More new posts: Seasons