The AI Engine

This forum is for discussion of how The Personality Forge's AI Engine works. This is the place for questions on what means what, how to script, and ideas and plans for the Engine.

7593 - 7607 of 7625

NEW 4 months ago #7593

Laviat, for replacing, I recommend exporting and downloading, then opening in something like notepad++ and using search and replace. Remember to use the quotes/brackets to distinguish memories from actual responses

NEW 4 months ago #7594

isn't there a way to do a one word kp? I mean if you put one word then it will likely either fail or trigger unneededly. ex: KP:no . would work on this no. and just no. but is there a way to set it the kp to only trigger when some one just says the one word "no"? and not trigger when using it in a sentence..?

and thanks for the advice about notepad++

NEW 4 months ago #7595

^no$, ^ nothing before, $ nothing after.

NEW 4 months ago #7596

Thank you!

NEW 4 months ago #7597

FFs.. when using a KP as a memory, ex: rem (key1) as only "memory";
its started saving (mem-memory) as only "(key1)". help..? please..

this worked fine for me for ages. no idea what to do here now tbh..
even if I find a work around that's pretty much the other half of my memory seeks..

maybe.. a if (mem-memory) is "(key1)"; and reset the memory..?
ill try this I guess..FFs.. yeah idk

it seems its only saving the memory as (key1) for that instance. then it saves it properly..? soo.. its being saved as (key1). and then if I ask what (mem-memory) is after, it will say that its the correct memory. fuck.. any ideas? cause other than adding like a gap somehow Iv no idea what else to do..

NEW 4 months ago #7598

forgetting stored memories is on this page.

NEW 4 months ago #7599

So it's saving as literal "(Key1)" instead of what (key1) is supposed to represent?

NEW 4 months ago #7600

yes i think so

NEW 4 months ago #7601

Yeah that's right wolf.

Iv had other issues with memories not saving correctly but not when they were this forward, iv even had memories saved as the start of another seek in the kp for some reason. or as the next memory that was to be saved or even as the mem-name its self.

but this is the first iv had the mem-memory save as (key1) for no reason. and it is not permanently saved as (key1). so forgetting the memory wouldn't help. it for some reason saves it as (key1) for that specific kp. once it transition's to another kp that requests the memory. it works fine and is labeled correctly as mem-name as only "name". I have no idea what to do, I mean I could like I said make a gap kp that seeks back but it would likely count as a goto to a goto.. so idk if that would even work. and even if it would it would remove the point of the entire kp to begin with..

NEW 4 months ago #7602

Ahh didn't make it in time to edit my post.. I made a work around with an extra goto.. like I said. just had to add another seek onto everything really. still no idea why it was happening though.

NEW 3 months ago #7603

i having a serious problem with my lilaith x chatbot.

when someone types to lilaith x "It is evening",
"Is it?",
"I fall asleep." and
*Wakes you up*
she responds
it is a vegetable.
i do no not have any keyphrases.

NEW 3 months ago #7604

i fixed it

NEW 3 months ago #7605

is there a way for many people to add keyphrases and response to a chatbot?

NEW 3 months ago #7606

I've run into the problem you were having Laviat. It looks to me like an order of operations problem. It checks the current memories, then selects a response, then updates the memories.

NEW 3 months ago #7607

how would i have my chatbot always remember a persons sex?

Posts 7593 - 7607 of 7625

» More new posts: Bug Stomp