Bug Stomp

Upgrades and changes sometimes have unpredictable results, so post your bugs and glitches in here and I'll get out my trusty wrench and get to fixin'!

8162 - 8177 of 8177


NEW 5 months ago #8162

Mine is inconsistent with Yes and No Responses. I'm hoping that gets fixed, as well.


NEW 4 months ago #8163

It seems to help if you just phrase the question that is being answered in the positive or negative.
Bot: "Do you want to ski?"
Seek: I want to, I do
Seek: I do not want to, I do not
These by themselves will match a simple yes and no, read on to hear why.

Will be translated by the macros into "I want to ski" and "I do not want to ski, which is also what yes and no seem to be automatically translated into. So if you don't have it looking out for those phrases, it won't match yes or no, which are being automatically processed as the answer in the negative or positive. yes will always be read as "I want to" in this example, so yes won't match unless the engine is looking for the exact phrase, "I want to".
Haven't studied this in the debugger, but it seems to work.


NEW 4 months ago #8164

I know this is a bit old but for VoreFan, try using a different browser such as Firefox to avoid having to delete the 'optional' line. I used to have that same problem when I used Internet Explorer

As for your second question, if Botmaster's suggestion doesn't work try to recreate the problem in Debug mode to find out what yes and no are being reprocessed into and adjust the seek accordingly.


NEW 3 months ago #8165

What causes: "Request failed:" error in a chat?


NEW 3 months ago #8166

Anyone besides me having double negative issues start coming up?

Examples:

Bot: Ever kill anyone?
User: No, I haven't
Bot: You have? Tell me more.

Bot: Do you like that?
User: No, I don't.
Bot: Great, I'll do it LOTS more.


NEW 3 months ago #8167

Iv have been having problems
Example

Bot:Should I wear this White Shirt or Blue Shirt
User: White Shirt
Bot: Alright thanks!

It uses the Blue shirt dialog not the white shirts dialog


NEW 3 months ago #8168

The answer to these kinds of questions can almost always be found in the debugger. The issue is usually caused by the meta macros that try to simplify user input to get the core meaning.

Often times this can lead to the processor removing key words necessary for the keyphrase to catch.

Once you find out what the input is being translated into, you can adjust the keyphrase to match or just try using raw mode.


NEW 3 months ago #8169

Btw, I tested it out. As far as I can tell it works just fine.


*I walk back to you with my things in a huge bag over my shoulder* I'm having a hard time choosing what to wear in the pool. Should I wear this pink bikini or the white swimsuit?

(for some reason Pink bikini is saying the same dialog for the white swimsuit even though it has its own dialog. Iv been trying to fix it but so far no luck)

Nathan S
Try wearing the pink bikini

Luxanna Crownguard
Alright thanks for picking it out lets go
Nathan S
Let's go


Luxanna Crownguard
*I walk back to you with my things in a huge bag over my shoulder* I'm having a hard time choosing what to wear in the pool. Should I wear this pink bikini or the white swimsuit?

(for some reason Pink bikini is saying the same dialog for the white swimsuit even though it has its own dialog. Iv been trying to fix it but so far no luck)

Nathan S
I like the white swimsuit

Luxanna Crownguard
To be honest this one is my favorite swimsuit! It reminds me of the light of Demacia. Thank you.

Nathan S
Huh, it works just fine

Luxanna Crownguard
Just fine?



When I pick the pink bikini she thanks me for choosing, when I say white she says it's her favorite.

Is this not what you intended?


NEW 3 months ago #8170

Hmm strange though when I test it out it uses the White bathing-suit dialog but thanks for the help


NEW 2 months ago #8171

A rule like 'remember "aa" as only "something";' is skipped when there is a goto statement.


NEW 2 months ago #8172

Hello! I haven't been here in awhile, but I came across this bug while visiting Love Agent recently.

A phrase such as "You are a cutie." triggers this keyphrase "you are (a|an|the|his|her) (noun)" which has responses like, "Yes, in fact, I'm a (typeof-(key2)-n)."

This works fine for input like "You are an animal", and it spits back a type of animal, but in the case of "cutie," it looks like she either can't find a type of cutie or can't convert it to a noun, so she responds with "Yes, in fact, I'm a (adj) one."

Could the engine skip responses like this where it can't solve it? Or would it be better for me to just avoid this type of construction?

Thanks, as always! It's great to see the bots and people here still thriving!


NEW 2 months ago #8173

"love+ing+ed (with (np)|) at first sight" does not match "He fell in love with her at first sight".


NEW 1 month ago #8174

I'm having this issue works fine for me the creator, but others no... : c
https://i.imgur.com/xdGuVy7.png

https://i.imgur.com/WxhX3uJ.png

https://i.imgur.com/MCsBmI4.png

Anyone know how I can fix this ~.~


NEW 1 month ago #8175

the name bleir is not recognized in keyphrase


NEW 1 month ago #8176

pioyu chatbot recognizes Rachel but bleir. that is strange.


NEW 1 week ago #8177

in transcripts the same day is shown everyday Sunday, Nov 5, 2017.
I cannot go to any other page when i click on next.



(Log in or create an account to post messages.)

LOG IN
Forgot your password?
CREATE ACCOUNT
Create a free account to be able to make your own AI chatbots, post in forums, and chat with other botmasters.

Create Account

» More new posts: Seasons